• Home
  • Blog
  • Vulnerabilità Prestashop dovuta da alcune versioni di PHPUnit

Vulnerabilità Prestashop dovuta da alcune versioni di PHPUnit

E’ notizia di questi giorni, che moltissimi e-commerce sono sotto attacco a causa della vulnerabilità scoperta per alcune versioni del componente PHP, utilizzato per l’esecuzione automatica di script esterni, su diversi moduli, il problema è stato etichettato CVE-2017-9841 [2] [3]

Quali sono gli ecommerce a rischio?

Principalmente si tratta di tutti gli e-commerce con la versione 1.7 e dei suoi moduli, ma può interessare anche versioni precedenti, 1.6, che hanno installate versioni vulnerabili.

Purtroppo in questo caso, aggiornare la versione di Prestashop e i relativi moduli per limitare i danni, com’è giusto che sia, hanno dato risultato opposto…

ma stando sempre sul pezzo, abbiamo la possibilità di correre ai ripari, prima che qualcuno si accorga di ciò.

Come verificare se il proprio e-commerce sia stato hackerato o sia vulnerabile?

di seguito mettiamo la lista dei moduli e delle rispettive versioni, che ad oggi sono stati accertati come vulnerabili, anche se si stanno scoprendo sempre più moduli e versioni compromesse o compromissibili, per questo vi consigliamo di controllare i Vostri shop a prescindere.

Di seguito quelli già stati identificati come vulnerabili :

OneClick Upgrade (Aggiornamento in 1 click) – Versioni 4.x 
Cart Abandonment Pro (Carrelli Abbandonati) – Versioni 2.0.1 e 2.0.2
PS Checkout (Prestashop Checkout) – Versioni 1.0.8 e 1.0.9
Faceted Search (Ricerca per Aspetti) – Versione 3.0.0

“Purtroppo abbiamo confermato che anche le versioni phpunit> 5.6.3 sono vulnerabili.
Esiste davvero la vulnerabilità https://nvd.nist.gov/vuln/detail/CVE-2017-9841 e c’è un’altra vulnerabilità che non è stata ancora segnalata che ha un impatto su phpunit fino al 7.5.19 | 8.5.1 (queste 2 versioni sono le 2 versioni patchate)”.

Il lavoro di ricerca sta procedendo proprio in queste ore, per analizzare tutti i possibili moduli interessati, ma nel frattempo, controllare nella cartella “vendor” sia presente una cartella nominata phpunit, controllando che la versione non sia tra quelle individuate come vulnerabili.

Come proteggersi da questa vulnerabilità una volta accertata?

Visto che le versioni vulnerabili di PHPUnit sono solamente alcune, è in ogni caso possibile cancellare in tutta sicurezza la cartella /vendor/phpunit da qualsiasi modulo senza comprometterne il funzionamento, chiaramente è un’operazione delicata che andrebbe svolta da personale qualificato, onde evitare problemi, siamo qui per darvi supporto e fornirvi la soluzione “chiavi in mano”.

Contattami Ora

Come scoprire se il tuo e-commerce è in pericolo?

Vista l’estrema facilità di compromissione che scaturisce da questa falla, le possibilità di hackeraggio sono molto alte, su tutti gli shop, pertanto fare molta attenzione e capire se effettivamente siamo stati attaccati o meno, per aiutare a trovare queste backdoor è obbligatorio verificare l’eventuale inclusione di questo framework di test in ogni sottocartella della radice Web. Quindi, per accelerare il tutto, con il collega Massimiliano Brasile abbiamo scritto questo piccolo script veloce e sporco che ci aiuta a controllare tutte le istanze di Prestashop o WordPress di cui sono responsabile.

clicca per scaricare lo script   👈

SE HAI BISOGNO DI SUPPORTO NON ESITARE A CONTATTARMI, SARO’ FELICE DI POTERTI AIUTARE.

Submit your review
1
2
3
4
5
Submit
     
Cancel

Create your own review

Alexander Greco - consulente seo
Average rating:  
 2 reviews
by Mario Casamenti on Alexander Greco - consulente seo

Rapido efficiente, economico e professionale, che altro vi aspettate da un professionista?

by francesco bicanti on Alexander Greco - consulente seo

Avere una persona che segue la parte sistemistica con l'attenzione che ci mette Alexander è veramente utile quando si verificano problemi di questa portata.
Avevamo il sito compromesso, è stato analizzato, risolto e pulito con la solita professionalità e competenza che lo contraddistingue.

Summary
Article Name
Vulnerabilità Prestashop dovuta da alcune versioni di PHPUnit
Description
Scoperta una nuova vulnerabilità di Prestashop, dovuta da versioni di PHPUnit compromesse, che danno la possibilità ai malintenzionati di entrare nel vostro sito.
Author

Italia

Via Romagna 62

05100 Terni (TR)

Spagna

Calle El Hoyo 3

Los menores

38678 Adeje Tenerife

Alexander Greco     Privacy Policy

%d blogger hanno fatto clic su Mi Piace per questo: